Having trouble with your Festool power tool? Well, we're here to help you. Before posting to the forum, give us a chance to diagnose and resolve your issue. In the U.S. and Canada, call us toll-free at 888-337-8600 on Monday-Friday between 8a-5p EST or contact us via email at service@festoolusa.com. For other countries, please visit http://www.festool.com for contact information for your local Festool service department.

Author Topic: Ets 150/5 issues  (Read 3954 times)

0 Members and 1 Guest are viewing this topic.

Offline ryansmythe

  • Posts: 38
Ets 150/5 issues
« on: March 03, 2007, 03:40 PM »
Has anyone here ever had electrical problems with any of your festools. i got a new ets 150/5 used it for 20 min no problem stopped for a while and went back to sanding and i think it shorted out. sounded like it was backfiring and then it just died. any ides what the problem might have been?

Thanks.

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline Les Spencer

  • Posts: 487
Re: Ets 150/5 issues
« Reply #1 on: March 03, 2007, 08:47 PM »
I had a bad switch on my new ls 130. Wouldn't let me lock on then finally quit after 10-15 minutes. No strange sounds.
Les (near Indy) XL

Offline powertoolworld

  • Festool Dealer
  • *
  • Posts: 11
    • powertoolworld
Re: Ets 150/5 issues
« Reply #2 on: March 08, 2007, 11:21 AM »
The ets150/5 is a total workhorse and I am very surprised that it went wrong in 20 mins. Ive supplied this to factories working 24 hours a day and is used non stop.  I would take it back to the dealer where you bought it from and ask for a new tool (this only works within the first week or so after purchase). If not then the 3 year warranty will cover it.

Offline ryansmythe

  • Posts: 38
Re: Ets 150/5 issues
« Reply #3 on: March 09, 2007, 09:41 PM »
i did get it replaced but i was just wondering if anyone else had the same problem. 

Offline Matthew Schenker

  • Posts: 2619
Re: Ets 150/5 issues
« Reply #4 on: May 15, 2007, 02:01 PM »
Coming a bit late to this discussion, but wanted to add my comments...

I've been using the 150/5 a lot over the last couple of years.  It gets heavy use, and I've never seen it fail.  It runs really smooth and collects dust like the day it entered my shop.
FOG Designer and Creator

Offline bill-e

  • Posts: 504
  • Rindge, New Hampshire, USA
    • New Hampshire Woodworker
Re: Ets 150/5 issues
« Reply #5 on: May 17, 2007, 10:24 PM »
It gets heavy use, and I've never seen it fail.  It runs really smooth and collects dust like the day it entered my shop.
I have a lot of things that collect dust in my shop since going Festool ;)