Having trouble with your Festool power tool? Well, we're here to help you. Before posting to the forum, give us a chance to diagnose and resolve your issue. In the U.S. and Canada, call us toll-free at 888-337-8600 on Monday-Friday between 8a-5p EST or contact us via email at service@festoolusa.com. For other countries, please visit http://www.festool.com for contact information for your local Festool service department.

Author Topic: TS 55 Thermal Sensor  (Read 1079 times)

0 Members and 1 Guest are viewing this topic.

Offline Lbob131

  • Posts: 429
TS 55 Thermal Sensor
« on: April 01, 2017, 02:50 PM »
I was nearing    nearing the end of  ripping  60  plywood  strips  2.4m long and my ts 55  seemed to cut out  in the cut. When I released the plunge  it still operated  but at a much lower rpm.
The housing  didn't seem that warm.
Is that the thermal sensor cutting in to protect the tool?

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline SRSemenza

  • Global Moderator
  • *
  • Posts: 7732
  • Finger Lakes Region, NY State , USA
Re: TS 55 Thermal Sensor
« Reply #1 on: April 01, 2017, 09:35 PM »
Yes, there is a an overheat protection on the TS55. I have had it happen. What you describe sounds like that is probably the cause. It should return to normal after a cool off.  If not then something else is going on.

Seth