Author Topic: Classic Engineering quick connect bit stuck?  (Read 1187 times)

0 Members and 1 Guest are viewing this topic.

Offline billberner

  • Posts: 12
Classic Engineering quick connect bit stuck?
« on: March 17, 2018, 10:29 PM »
I was boring a door with a Classic Engineering boring jig and one of the bits got stuck in the 'quick release' bit holder. Anyone else had this happen and figured out how to get the bit loose?  I fiddled with it for about 15-20 minutes today and decided to let it sit a bit.  Worst case I guess I saw the bit in half and buy a new borer+ quick connect bit, but I'd rather not do that (and I'd rather be 'back in business' faster).

Thanks in advance for any help. 

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline Mario Turcot

  • Posts: 379
Re: Classic Engineering quick connect bit stuck?
« Reply #1 on: March 17, 2018, 11:44 PM »
Happen to me with the Lee Valley quick change bit holder. I happen to have 3 so the tork bit is still in it :)

I tried everything I could w/o breaking it and couldn't get it out :(

Mario
Mario

Offline Alex

  • Posts: 5668
Re: Classic Engineering quick connect bit stuck?
« Reply #2 on: March 18, 2018, 02:26 AM »
Douche it with WD40, let it sit for a while and then try again to remove the bit.

Offline mobetta

  • Posts: 14
Re: Classic Engineering quick connect bit stuck?
« Reply #3 on: April 06, 2018, 06:21 PM »
I've had issues with similar connectors. Lubrication will help.
A vicegrip snugged onto the outer collar, gentle tapping with a modest hammer.
RO125  pro 5  DTS400
DF500  DF700  TSC55  HKC55  TS55
DWC-18 Planex CT36AC  CT36  CTMidi  Ctsys x2