Having trouble with your Festool power tool? Well, we're here to help you. Before posting to the forum, give us a chance to diagnose and resolve your issue. In the U.S. and Canada, call us toll-free at 888-337-8600 on Monday-Friday between 8a-5p EST or contact us via email at service@festoolusa.com. For other countries, please visit http://www.festool.com for contact information for your local Festool service department.

Author Topic: How does the CTICT Midi connect to the T-Lock Systainer?  (Read 1230 times)

0 Members and 1 Guest are viewing this topic.

Offline kevintunis

  • Posts: 1
I set my Domino  T-Lock Systainer box on top and locked it with the T-Lock. When you go to move it or pick it up it just tilts and unlocks. I acts like the back is not locking in.

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline neilc

  • Posts: 2758
Re: How does the CTICT Midi connect to the T-Lock Systainer?
« Reply #1 on: March 31, 2018, 07:31 PM »
The hose and cord on the Mini and Midi will cause the T-loc to not fully engage in the back catch.  Work to make sure the cord and hose are down low enough and you can get the T-loc to latch.  I was dealing with this today.  I put the hose in first and then coil the cord into the empty space and press it down before putting the Systainer on top.  I believe the new hoses that Festool is now shipping might make this easier to deal with.